[Install help neede...
 
Share:
Notifications
Clear all

[Solved] [Install help needed] When browsing to console getting "Access Denied" after a fresh install  

   RSS

0

Getting this error when browsing to the site after successfully installed DB, service, and web site (and setting the 1-year community edition license key)...

Access Denied

Reason: You have not been granted access to this site.

Have tried install on couple of different servers with same result.   Double-checked that I set myself (with my domain\username) as admin during install which the Access Denied message is stating does not have access.   Added a secondary admin as well during install as well, and also don't have access.

If I enable site Authentication method of ASP.NET Impersonation, then I get a 500 Internal Server error.

Tried on Windows Server 2016 and 2019.

IIS 10

Tried with both SQL Server 2016 and 2017.

 

This topic was modified 2 weeks ago 2 times by Joe Rykowski
3 Answers
0

While logged in as the user running the database installer, go to the %temp% folder and look for recent log files that start with "SFDB". You will see the actual error details there. The application pool account that you specify during the database install will be added to the SystemFrontier database with sysadmin rights. There is an outstanding bug with the installer where it may fail if the account is already a login in SQL Server. Using a new service account usually yields better results.

0

The account you are accessing the web interface with must either be the same one that was used to run the database setup or was added as an additional administrator during the setup. If it was a different account, you can connect to the web interface the first time as the installer user, then add your normal account to the SFSA role. You can verify if an active account was configured correct on the back end by checking the UserAccounts table in the SystemFrontier database using SQL Server Management Studio.

 

As long as you check the IIS install / update option during the web setup, all the correct options for authentication will be configured by default for you.

 

Let me know if you still aren't able to get in after checking those things.

@onescripter

Thanks for clue... checked UserAccount table and it's empty. Recall now that the DB installer threw an "external error" when ran the first time, I re-ran and it finished "update" cleanly so thought all was good. Apparently there's something to dig into with the DB installer.

Is there a way to review installer log?

0
Posted by: @onescripter

There is an outstanding bug with the installer where it may fail if the account is already a login in SQL Server. Using a new service account usually yields better results.

That was root cause, thanks!   SF has been successfully setup on test system using an account not already in SQL Server.

Did also located the SF logs in %TEMP% folder.

Might consider putting a link from https://www.systemfrontier.com/kb/install-database/ to a Troubleshooting guide that includes mention of that logs location.   Known issue list would be great as well.

Have a blank slate now, and excited to begin playing with SystemFrontier.   Thanks for your help!

I saw the presentation about SF at devopsorg 24-hour devops streaming event… <a href=" removed link "> removed link

@user3676697
That's great news Joe and great feedback. We'll get the KB updated with that information to make troubleshooting the DB install a little easier.

Thanks for tuning into the 24-hour PowerShell event. It was a fun event! https://powershell.org/24hour/

Share: